About this Article

This article is intended for use by the Exchange Administrator to determine if the install works properly.

Testing the system


Once you have configured the security settings, before you deploy the signatures to all OWA users, you need to test that the OWA module works properly.


To test the system, we recommend that you try it for a few users to verify that the security settings are good and that everything works as it should.


In order to test for a few users follow these steps. In the example we test for the users JOHNDOE and ADMIN:


  1. Open the Modules tab in the admin console and click Configuration button for Outlook Web Access. The Basic Configuration window appears. Please verify that the settings are valid.

  2. Open the Status Monitor from the 'Diagnostics' tab where you can see the deployment status of your users. Please only select those users for whom the signatures are correctly deployed. In order to enable the test for specific users please scroll horizontally to the right and select the checkmark in the column ‘OWA Test’ for those users whose signatures will be tested.


  3. To deploy the test signatures, run signOWA.exe manually with debug messages. Open the command prompt and write C:\>signOWA.exe -v The command prompt will show the progress similar to the following screen.



    When you see a status 'HTTP/1.1 200 OK' the signature is deployed successfully.

    Both the signOWA.exe and the BM.signOWA.dll files must be located in the same folder for the program to function correctly.

  4. Open the test users' mail boxes from OWA to check that the signatures are deployed as expected.

  5. If the signatures are deployed correctly, before going 'Live' clear all check-marks for the users you have selected for this test. 


Please remember that you need to be logged off OWA when performing changes to your default signature in OWA.